0001-path-substitution.patch 26.14 KiB
From: Kill Your TV <killyourtv@i2pmail.org>
Date: Mon, 18 Apr 2011 16:43:40 +0000
Subject: path substitution
The purpose of this patch is the change the values handled by
the Izpack based installer.
Non-applicable sections (e.g., portable & windows) are also removed for the
Debian wrapper.config to try to prevent confusion.
---
installer/resources/eepget | 2 +-
installer/resources/i2prouter | 82 ++++--------------------------------
installer/resources/runplain.sh | 4 +-
installer/resources/wrapper.config | 70 ++++++------------------------
4 files changed, 24 insertions(+), 134 deletions(-)
--- a/installer/resources/eepget
+++ b/installer/resources/eepget
@@ -1,3 +1,3 @@
#!/bin/sh
-I2P="%INSTALL_PATH"
+I2P="/usr/share/i2p"
java -cp "$I2P/lib/i2p.jar" net.i2p.util.EepGet "$@"
--- a/installer/resources/i2prouter
+++ b/installer/resources/i2prouter
@@ -10,7 +10,7 @@
# wrapper configuration file.
#
# If this script fails to successfully invoke i2psvc on your platform,
-# try the runplain.sh script instead.
+# try the i2prouter-nowrapper script instead.
#
# This software is the proprietary information of Tanuki Software.
# You shall use it only in accordance with the terms of the
@@ -24,21 +24,12 @@
# These settings can be modified to fit the needs of your application
# Optimized for use with version 3.5.22 of the Wrapper.
-# Paths
-# Note that (percent)INSTALL_PATH, (percent)USER_HOME, and (percent)SYSTEM_java_io_tmpdir
-# should have been replaced by the izpack installer.
-# If you did not run the installer, replace them with the appropriate paths.
-I2P="%INSTALL_PATH"
-if [ "`uname -s`" = "Darwin" ]; then
- if [ -d "%USER_HOME/Library/Application Support" ]; then
- I2P_CONFIG_DIR="%USER_HOME/Library/Application Support/i2p"
- else
- I2P_CONFIG_DIR="%USER_HOME/.i2p"
- fi
-else
- I2P_CONFIG_DIR="%USER_HOME/.i2p"
-fi
-I2PTEMP="%SYSTEM_java_io_tmpdir"
+# Read config file if found
+[ -f /etc/default/i2p ] && . /etc/default/i2p
+
+I2P="/usr/share/i2p"
+I2P_CONFIG_DIR="$HOME/.i2p"
+I2PTEMP="/tmp"
# PORTABLE installation:
# Use the following instead.
#I2PTEMP="%INSTALL_PATH"
@@ -69,8 +60,8 @@
#RUN_AS_USER=
# Wrapper
-WRAPPER_CMD="$I2P/i2psvc"
-WRAPPER_CONF="$I2P/wrapper.config"
+WRAPPER_CMD="/usr/sbin/wrapper"
+WRAPPER_CONF="/etc/i2p/wrapper.config"
# Priority at which to run the wrapper. See "man nice" for valid priorities.
# nice is only used if a priority is specified.
@@ -177,75 +168,8 @@
exit 1
fi
-# Workaround for Gentoo
JAVABINARY=$(awk -F'=' '/^ *wrapper\.java\.command/{print $2}' "$WRAPPER_CONF")
-if [ -e /etc/gentoo-release ]; then
- if [ $JAVABINARY = java ]; then
- if [ -x /etc/java-config-2/current-system-vm/bin/java ]; then
- JAVABINARY="/etc/java-config-2/current-system-vm/bin/java"
- else
- echo "Please set wrapper.java.command in $WRAPPER_CONF"
- exit 1
- fi
- fi
-fi
-
-WRAPPER_URL="https://geti2p.net/en/misc/manual-wrapper"
-unsupported() {
- echo "The most likely reason is that a supported version of the java"
- echo "wrapper is not available in the I2P installation package for your"
- echo "platform. It may be possible to manually download and install"
- echo "a compatible wrapper for your system."
- echo "See ${WRAPPER_URL} for hints."
- echo
- echo "In the meantime, you may start I2P by running the script"
- echo "${I2P}/runplain.sh"
- echo
-}
-
-freebsd10() {
- echo
- echo "The current version of the Tanuki wrapper does not"
- echo "support FreeBSD 10."
- echo
- echo "See https://trac.i2p2.de/ticket/1118 for more information"
- echo "and a workaround for this issue."
- echo
- echo "In the meantime, you may start I2P by running the script"
- echo "${I2P}/runplain.sh"
- echo
-}
-
-failed() {
- echo "**`gettext 'Failed to load the wrapper'`**"
- case `uname -s` in
- FreeBSD)
- case `uname -r` in
- 10*|11*)
- freebsd10
- ;;
- *)
- # We should never get here on recent versions of FreeBSD
- if ! $(pkg_info -E 'libiconv*' > /dev/null 2>&1); then
- echo
- echo "The wrapper requires libiconv."
- echo
- echo "It can be installed with pkg_add -r libiconv"
- echo
- fi
- ;;
- esac
- ;;
-
- *)
- echo
- unsupported
- ;;
- esac
- exit 1
-}
-
if [ -n "$FIXED_COMMAND" ]
then
COMMAND="$FIXED_COMMAND"
@@ -1058,7 +982,6 @@
if [ "X$pid" = "X" ]
then
eval echo " `gettext 'WARNING: $APP_LONG_NAME may have failed to start.'`"
- failed
else
eval echo ' running: PID:$pid'
fi
@@ -1861,7 +1784,7 @@
}
showsetusermesg() {
- echo "`gettext 'Please edit i2prouter and set the variable RUN_AS_USER'`."
+ echo "`gettext 'Please edit /etc/default/i2p and set the variable RUN_AS_USER'`."
}
checkifstartingasroot() {
@@ -1869,7 +1792,7 @@
echo "`gettext 'Running I2P as the root user is *not* recommended.'`"
showsetusermesg
echo
- echo "`gettext 'To run as root anyway, edit i2prouter and set ALLOW_ROOT=true.'`"
+ echo "`gettext 'To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true.'`"
exit 1
fi
}
@@ -1934,24 +1857,10 @@
status
;;
- 'install')
- installdaemon
- if [ ! `grep ^RUN_AS_USER $0` ]; then
- echo
- showsetusermesg
- fi
- echo
- echo "You may want to disable the browser from launching at startup at"
- echo "http://127.0.0.1:7657/configclients"
- echo
- echo "I2P_CONFIG_DIR is currently set to $I2P_CONFIG_DIR."
- echo "Change the value in $0 if this is not"
- echo "appropriate for your configuration."
- ;;
-
- 'remove' | 'uninstall')
- removedaemon
- ;;
+ 'install' | 'remove' | 'uninstall')
+ echo "Use \"dpkg-reconfigure i2p\" to configure the initscript."
+ exit 1
+ ;;
'dump')
checkUser "" "$COMMAND"
--- a/installer/resources/runplain.sh
+++ b/installer/resources/runplain.sh
@@ -11,8 +11,8 @@
# Note that (percent)INSTALL_PATH and (percent)SYSTEM_java_io_tmpdir
# should have been replaced by the izpack installer.
# If you did not run the installer, replace them with the appropriate path.
-I2P="%INSTALL_PATH"
-I2PTEMP="%SYSTEM_java_io_tmpdir"
+I2P="/usr/share/i2p"
+I2PTEMP="/tmp"
# Having IPv6 enabled can cause problems with certain configurations. Changing the
# next value to true may help.
--- a/installer/resources/wrapper.config
+++ b/installer/resources/wrapper.config
@@ -8,22 +8,13 @@
# click "Shutdown", wait 11 minutes, then start i2p.
#
# WARNING - The wrapper is NOT run (and this file is not used)
-# if you start I2P with the 'no window' icon on Windows, or
-# with the runplain.sh script on Linux. Use the 'restartable'
-# icon on Windows or the i2prouter script on Linux to run the wrapper.
+# if you start I2P with the i2prouter-nowrapper script in Linux.
+# Use i2prouter or the initscript to run the wrapper.
#
# NOTE - Directory organization:
# The standard I2P Installation will set up a "split" directory structure
# with code in the install directory, data and configuration files in the
# user's home directory, and temporary files in the system temporary directory.
-# To set up a single-directory "portable" installation suitable for
-# a USB stick, make several changes specified below (search for PORTABLE).
-#
-# NOTE - The izpack installer performs variable subsitiution on this
-# file upon installation. If you did not use izpack, you must
-# find and replace all instances of (dollar)INSTALL_PATH and
-# (dollar)SYSTEM_java_io_tmpdir with appropriate values
-# (perhaps . and /var/tmp, respectively)
#
#********************************************************************
# Java Application
@@ -60,13 +51,14 @@
# classes, or all the classes of i2p.jar, are in a different directory).
# Be sure there are no other duplicate classes.
#
-wrapper.java.classpath.1=$INSTALL_PATH/lib/*.jar
+wrapper.java.classpath.1=/usr/share/i2p/lib/*.jar
+wrapper.java.classpath.2=/usr/share/java/wrapper.jar
# uncomment this to use the system classpath as well (e.g. to get tools.jar)
-# wrapper.java.classpath.2=%CLASSPATH%
+# wrapper.java.classpath.3=%CLASSPATH%
-# Java Library Path (location of Wrapper.DLL or libwrapper.so)
-wrapper.java.library.path.1=$INSTALL_PATH
-wrapper.java.library.path.2=$INSTALL_PATH/lib
+# Java Library Path (location of libjbigi/libjcpuid)
+wrapper.java.library.path.1=/usr/lib/jni
+wrapper.java.library.path.2=/usr/share/java/lib
# Java Bits. On applicable platforms, tells the JVM to run in 32 or 64-bit mode.
wrapper.java.additional.auto_bits=TRUE
@@ -74,7 +66,7 @@
# Java Additional Parameters
# Numbers must be consecutive (except for stripquotes)
wrapper.java.additional.1=-DloggerFilenameOverride=logs/log-router-@.txt
-wrapper.java.additional.2=-Di2p.dir.base="$INSTALL_PATH"
+wrapper.java.additional.2=-Di2p.dir.base=/usr/share/i2p
wrapper.java.additional.2.stripquotes=TRUE
# Prevent the JVM from exporting stats (and thereby causing hundreds of
@@ -146,11 +138,7 @@
# You may wish to change this.
# NOTE: On Linux/Mac this is overridden in the i2prouter script; changes here will have no effect.
# System temp directory:
-wrapper.logfile=$SYSTEM_java_io_tmpdir/wrapper.log
-# PORTABLE installation:
-# Use the following instead. I2P will find the logfile here,
-# no need for a wrapper.java.additional line too.
-#wrapper.logfile=$INSTALL_PATH/wrapper.log
+#wrapper.logfile=/tmp/wrapper.log
# Format of output for the log file.
# The format consists of the tokens 'L' for log level, 'P' for prefix, 'D' for thread,
@@ -220,11 +208,7 @@
# Linux/Mac users, do not set here, see settings in the i2prouter script.
# Directory must exist or the wrapper will fail to start.
# System temp directory:
-#wrapper.java.pidfile=$SYSTEM_java_io_tmpdir/routerjvm.pid
-# PORTABLE installation:
-# Use the following instead.
-#wrapper.java.pidfile=$INSTALL_PATH/routerjvm.pid
-# pid file for the service monitoring the JVM
+#wrapper.java.pidfile=/tmp/routerjvm.pid
#
# From i2prouter:
#
@@ -238,10 +222,7 @@
# Linux/Mac users, do not set here, see settings in the i2prouter script.
# Directory must exist or the wrapper will fail to start.
# System temp directory:
-#wrapper.pidfile=$SYSTEM_java_io_tmpdir/i2p.pid
-# PORTABLE installation:
-# Use the following instead.
-#wrapper.pidfile=$INSTALL_PATH/i2p.pid
+#wrapper.pidfile=/tmp/i2p.pid
#********************************************************************
# Wrapper General Properties
@@ -258,30 +239,3 @@
wrapper.umask=0022
wrapper.java.umask=0022
wrapper.logfile.umask=0077
-
-#********************************************************************
-# Wrapper NT Service Properties
-#********************************************************************
-# WARNING - Do not modify any of these properties when an application
-# using this configuration file has been installed as a service.
-# Please uninstall the service before modifying this section. The
-# service can then be reinstalled.
-
-# Name of the service
-wrapper.ntservice.name=i2p
-
-# Display name of the service
-wrapper.ntservice.displayname=I2P Service
-
-# Description of the service
-wrapper.ntservice.description=The I2P router service
-
-# Service dependencies. Add dependencies as needed starting from 1
-wrapper.ntservice.dependency.1=
-
-# Mode in which the service is installed. AUTO_START or DEMAND_START
-wrapper.ntservice.starttype=AUTO_START
-
-# Allow the service to interact with the desktop.
-wrapper.ntservice.interactive=false
-
--- a/installer/resources/locale/po/messages_de.po
+++ b/installer/resources/locale/po/messages_de.po
@@ -195,15 +195,15 @@
msgstr "Falls gestartet, fordere einen Java Thread dump an"
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "Bitte bearbeite i2prouter und setze die Variable RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "Bitte bearbeite /etc/default/i2p und setze die Variable RUN_AS_USER"
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
msgstr "I2P als root Benutzer auszuführen ist *nicht* empfehlenswert."
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
msgstr ""
-"Um I2P trotzdem als root auszuführen bearbeite i2prouter und setze "
+"Um I2P trotzdem als root auszuführen bearbeite /etc/default/i2p und setze "
"ALLOW_ROOT=true."
--- a/installer/resources/locale/po/messages_en.po
+++ b/installer/resources/locale/po/messages_en.po
@@ -185,7 +185,7 @@
msgstr ""
#: ../i2prouter:1825
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
msgstr ""
#: ../i2prouter:1830
@@ -193,5 +193,5 @@
msgstr ""
#: ../i2prouter:1833
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
msgstr ""
--- a/installer/resources/locale/po/messages_it.po
+++ b/installer/resources/locale/po/messages_it.po
@@ -187,7 +187,7 @@
msgstr ""
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
msgstr ""
#: ../i2prouter:1812
@@ -195,5 +195,5 @@
msgstr ""
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
msgstr ""
--- a/installer/resources/locale/po/messages_zh.po
+++ b/installer/resources/locale/po/messages_zh.po
@@ -187,13 +187,13 @@
msgstr "请求Java转储(如果在运行)。"
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "请编辑 i2prouter 设置 RUN_AS_USER 变量"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "请编辑 /etc/default/i2p 设置 RUN_AS_USER 变量"
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
msgstr "推荐 *不要* 以 root 身份运行 I2P 。"
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
-msgstr "要以root运行,请编辑 i2prouter 并设置 ALLOW_ROOT=true。"
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
+msgstr "要以root运行,请编辑 /etc/default/i2p 并设置 ALLOW_ROOT=true。"
--- a/installer/resources/locale/po/messages_tr.po
+++ b/installer/resources/locale/po/messages_tr.po
@@ -186,13 +186,13 @@
msgstr "Çalışıyorsa Java iş parçacığı dökümü isteyin."
#: ../i2prouter:1796
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "i2prouter dosyasını düzenleyin ve RUN_AS_USER değişkenini ayarlayın"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "/etc/default/i2p dosyasını düzenleyin ve RUN_AS_USER değişkenini ayarlayın"
#: ../i2prouter:1801
msgid "Running I2P as the root user is *not* recommended."
msgstr "I2P yazılımının root olarak çalıştırmanız *önerilmez*."
#: ../i2prouter:1804
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
-msgstr "Root olarak çalıştırmak için i2prouter dosyasını düzenleyin ve ALLOW_ROOT=true ayarını yapın."
+msgid "To run as root anyway, edit /etc/defalt/i2p and set ALLOW_ROOT=true."
+msgstr "Root olarak çalıştırmak için /etc/default/i2p dosyasını düzenleyin ve ALLOW_ROOT=true ayarını yapın."
--- a/installer/resources/locale/po/messages_es.po
+++ b/installer/resources/locale/po/messages_es.po
@@ -193,15 +193,15 @@
msgstr "Solicitar un volcado del hilo JAVA si se está ejecutando."
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "Por favor edite i2prouter e introduzca la variable RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "Por favor edite /etc/default/i2p e introduzca la variable RUN_AS_USER"
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
msgstr "\"No\" se recomienda ejecutar I2P como root."
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
msgstr ""
-"Para ejecutar como root de todos modos, edite i2prouter y ponga la variable "
+"Para ejecutar como root de todos modos, edite /etc/default/i2p y ponga la variable "
"ALLOW_ROOT=true."
--- a/installer/resources/locale/po/messages_pt.po
+++ b/installer/resources/locale/po/messages_pt.po
@@ -189,15 +189,15 @@
msgstr "Requisitar o histórico Java se iniciado."
#: ../i2prouter:1796
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "Favor editar o arquivo i2prouter e configurar a variável RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "Favor editar o arquivo /etc/default/i2p e configurar a variável RUN_AS_USER"
#: ../i2prouter:1801
msgid "Running I2P as the root user is *not* recommended."
msgstr "Iniciar I2P como permissões root *não* é recomendado."
#: ../i2prouter:1804
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
msgstr ""
-"Para executar como root mesmo assim, editar o i2prouter e configurar a "
+"Para executar como root mesmo assim, editar o /etc/default/i2p e configurar a "
"variável ALLOW_ROOT=true."
--- a/installer/resources/locale/po/messages_fr.po
+++ b/installer/resources/locale/po/messages_fr.po
@@ -190,8 +190,8 @@
msgstr "Request a Java thread dump if running."
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "Veuillez éditer i2prouter et paramétrer la variable RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "Veuillez éditer /etc/default/i2p et paramétrer la variable RUN_AS_USER"
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
@@ -199,7 +199,7 @@
"Faire fonctionner I2P en tant qu'utilisateur root n'est *pas* recommandé."
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
msgstr ""
-"Pour exécuter en tant que root de toute façon, éditer i2prouter et mettre "
+"Pour exécuter en tant que root de toute façon, éditer /etc/default/i2p et mettre "
"ALLOW_ROOT=true."
--- a/installer/resources/locale/po/messages_ru.po
+++ b/installer/resources/locale/po/messages_ru.po
@@ -191,13 +191,13 @@
msgstr "Запросить дамп нитей Java, если запущено."
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "Пожалуйста, отредактируйте i2prouter и установите переменную RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "Пожалуйста, отредактируйте /etc/default/i2p и установите переменную RUN_AS_USER"
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
msgstr "Запускать I2P от имени root'а *НЕ* рекомендуется."
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
-msgstr "Чтобы всё равно запустить под root'ом, отредактируйте i2prouter и установите ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
+msgstr "Чтобы всё равно запустить под root'ом, отредактируйте /etc/default/i2p и установите ALLOW_ROOT=true."
--- a/installer/resources/locale/po/messages_sv.po
+++ b/installer/resources/locale/po/messages_sv.po
@@ -187,14 +187,14 @@
msgstr "Fråga efter en Java thread dump vid drift."
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "Var god ändra i2prouter och set variabeln RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "Var god ändra /etc/default/i2p och set variabeln RUN_AS_USER"
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
msgstr "Att köra I2P som användare root är *inte* rekommenderat."
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
msgstr ""
-"För att köra som root oavsett, ändra i2prouter och sätt ALLOW_ROOT=true"
+"För att köra som root oavsett, ändra /etc/default/i2p och sätt ALLOW_ROOT=true"
--- a/installer/resources/locale/po/messages_ro.po
+++ b/installer/resources/locale/po/messages_ro.po
@@ -187,15 +187,15 @@
msgstr "Solicitarea dump-ului firului Java daca este pornit"
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "Vă rugăm să editați i2prouter și setați variabila RUN_AS_USER "
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "Vă rugăm să editați /etc/default/i2p și setați variabila RUN_AS_USER "
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
msgstr "Rularea I2P ca root *nu* este recomandată."
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
msgstr ""
-"Pentru a rula ca root, oricum, editati i2prouter și setați ALLOW_ROOT = "
+"Pentru a rula ca root, oricum, editati /etc/default/i2p și setați ALLOW_ROOT = "
"true."
--- a/installer/resources/locale/po/messages_pt_BR.po
+++ b/installer/resources/locale/po/messages_pt_BR.po
@@ -187,13 +187,13 @@
msgstr ""
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "Por favor, edite i2prouter e especifique a variável RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "Por favor, edite /etc/default/i2p e especifique a variável RUN_AS_USER"
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
msgstr "Executar o roteador I2P como usuário root *não* é recomendado."
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
-msgstr "De qualquer forma, se quiser mesmo executar o roteador como root, edite i2prouter e ponha ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
+msgstr "De qualquer forma, se quiser mesmo executar o roteador como root, edite /etc/default/i2p e ponha ALLOW_ROOT=true."
--- a/installer/resources/locale/po/messages_pl.po
+++ b/installer/resources/locale/po/messages_pl.po
@@ -186,13 +186,13 @@
msgstr "Zażądaj zrzutu wątków Java jeśli jest uruchomiona."
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "Proszę edytuj i2prouter i ustaw zmienną RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "Proszę edytuj /etc/default/i2p i ustaw zmienną RUN_AS_USER"
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
msgstr "Nie jest polecane uruchamianie I2P jako root."
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
-msgstr "Aby uruchomić jako root, edytuj i2prouter i ustaw ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
+msgstr "Aby uruchomić jako root, edytuj /etc/default/i2p i ustaw ALLOW_ROOT=true."
--- a/installer/resources/locale/po/messages_ja.po
+++ b/installer/resources/locale/po/messages_ja.po
@@ -186,13 +186,13 @@
msgstr "起動中の場合、 Java スレッドダンプを要求"
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "i2prouter を編集して、変数 RUN_AS_USER を設定してください"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "/etc/default/i2p を編集して、変数 RUN_AS_USER を設定してください"
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
msgstr "root ユーザーとしての I2P の起動は推奨され*ません*。"
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
-msgstr "とにかく root として起動し、 i2prouter を編集して、ALLOW_ROOT=true と設定する。"
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
+msgstr "とにかく root として起動し、/etc/default/i2p を編集して、ALLOW_ROOT=true と設定する。"
--- a/installer/resources/locale/po/messages_sk.po
+++ b/installer/resources/locale/po/messages_sk.po
@@ -187,13 +187,13 @@
msgstr "Vyžiadať zrušenie vlákna Javy, ak je spustený."
#: ../i2prouter:1807
-msgid "Please edit i2prouter and set the variable RUN_AS_USER"
-msgstr "Prosím upravte i2prouter a nastavte premennú RUN_AS_USER"
+msgid "Please edit /etc/default/i2p and set the variable RUN_AS_USER"
+msgstr "Prosím upravte /etc/default/i2p a nastavte premennú RUN_AS_USER"
#: ../i2prouter:1812
msgid "Running I2P as the root user is *not* recommended."
msgstr "Spúšťať I2P ako root *nie* je odporúčané."
#: ../i2prouter:1815
-msgid "To run as root anyway, edit i2prouter and set ALLOW_ROOT=true."
-msgstr "Ak ho chcete spustiť ako root aj tak, upravte i2prouter a nastavte ALLOW_ROOT=true."
+msgid "To run as root anyway, edit /etc/default/i2p and set ALLOW_ROOT=true."
+msgstr "Ak ho chcete spustiť ako root aj tak, upravte /etc/default/i2p a nastavte ALLOW_ROOT=true."